読者です 読者をやめる 読者になる 読者になる

Your vimproc binary version is "xxxx", but vimproc version is "xxx".

NeoBudle で プラグインをアップデートしたら、
以下のエラーが出るようになった。

Your vimproc binary version is "xxx", but vimproc version is "xxx".

ググると以下の情報が・・・・
https://twitter.com/ShougoMatsu/status/308164898800685056

vimprocのバージョンが問題らしいので、とりあえず再インストールしてみる。

まずはディレクトリを削除。
# rm -fr .vim/bundle/vimproc

ディレクトリを削除した後で NeoBudle で削除すればよかったなと思い、
一応NeoBudleでも削除。
# vim +NeoBundleClean

ディレクトリを消した後は NeoBudle でインストールしてみる。
# vim +NeoBundleInstall

無事インストールはできたっぽい。

ただ、soファイルができていないのでmakeする。
# cd .vim/bundle/vimproc
# make

ちなみに、soファイルができていないとvimを立ち上げてから
以下のエラーが出ます。

          • -

vimproc's DLL: ".vim/bundle/vimproc/autoload/vimproc_mac.so" is not found. Please read :help vimproc and make it.

          • -

現状は問題なく動作しているからこれでいーか・・・。